import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|[^.])\\b(ISomething)\\b";
final String string = "Api.Resources.Things.Bits.ISomething //doesn't match\n"
+ "something : ISomething\n"
+ "List<ISomething>\n"
+ "something:ISomething\n"
+ "isomething ";
final String subst = "$1Namespace.$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}