$re = '/(^|[^.])\b(ISomething)\b/';
$str = 'Api.Resources.Things.Bits.ISomething //doesn\'t match
something : ISomething
List<ISomething>
something:ISomething
isomething ';
$subst = "$1Namespace.$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;