using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|[^.])\b(ISomething)\b";
string substitution = @"$1Namespace.$2";
string input = @"Api.Resources.Things.Bits.ISomething //doesn't match
something : ISomething
List<ISomething>
something:ISomething
isomething ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}