use strict;
my $str = 'Api.Resources.Things.Bits.ISomething //doesn\'t match
something : ISomething
List<ISomething>
something:ISomething
isomething ';
my $regex = qr/(^|[^.])\b(ISomething)\b/p;
my $subst = '$1Namespace.$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";