import Foundation
let pattern = #"(^|[^.])\b(ISomething)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Api.Resources.Things.Bits.ISomething //doesn't match
something : ISomething
List<ISomething>
something:ISomething
isomething
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1Namespace.$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)