re = /(^|[^.])\b(ISomething)\b/
str = 'Api.Resources.Things.Bits.ISomething //doesn\'t match
something : ISomething
List<ISomething>
something:ISomething
isomething '
subst = '$1Namespace.$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result