package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|[^.])\b(ISomething)\b`)
var str = `Api.Resources.Things.Bits.ISomething //doesn't match
something : ISomething
List<ISomething>
something:ISomething
isomething `
var substitution = "$1Namespace.$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}