const regex = /(^|[^.])\b(ISomething)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|[^.])\\b(ISomething)\\b', 'g')
const str = `Api.Resources.Things.Bits.ISomething //doesn't match
something : ISomething
List<ISomething>
something:ISomething
isomething `;
const subst = `$1Namespace.$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);