#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(^|[^.])\b(ISomething)\b"
Local $sString = "Api.Resources.Things.Bits.ISomething //doesn't match" & @CRLF & _
"something : ISomething" & @CRLF & _
"List<ISomething>" & @CRLF & _
"something:ISomething" & @CRLF & _
"isomething "
Local $sSubst = "$1Namespace.$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)