# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+)\s+(\w+).*/[\\command1{\1}] \\command2{\2}/g;t' <<< "bla morebla evenmorebla
bla morebla evenmorebla"