import Foundation
let pattern = #"(\w+)\s+(\w+).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
bla morebla evenmorebla
bla morebla evenmorebla
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[\\command1{\1}] \\command2{\2}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)