use strict;
my $str = 'bla morebla evenmorebla
bla morebla evenmorebla';
my $regex = qr/(\w+)\s+(\w+).*/p;
my $subst = '[\\\\command1{\\1}] \\\\command2{\\2}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";