using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\s+(\w+).*";
string substitution = @"[\\command1{\1}] \\command2{\2}";
string input = @"bla morebla evenmorebla
bla morebla evenmorebla";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}