// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w+)\s+(\w+).*").unwrap();
let string = "bla morebla evenmorebla
bla morebla evenmorebla";
let substitution = "[\\\\command1{\\1}] \\\\command2{\\2}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}