import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)\\s+(\\w+).*";
final String string = "bla morebla evenmorebla\n"
+ "bla morebla evenmorebla";
final String subst = "[\\\\command1{\\1}] \\\\command2{\\2}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}