# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(REPLACE_ME)/WAS_REPLACED/gim;t' <<< "Lorem ipsum dolor sit amet, REPLACE_ME consectetur adipiscing elit."