import re
regex = re.compile(r"(REPLACE_ME)", flags=re.IGNORECASE | re.MULTILINE)
test_str = "Lorem ipsum dolor sit amet, REPLACE_ME consectetur adipiscing elit."
subst = "WAS_REPLACED"
result = regex.sub(subst, test_str)
if result:
print(result)