// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)(REPLACE_ME)").unwrap();
let string = "Lorem ipsum dolor sit amet, REPLACE_ME consectetur adipiscing elit.";
let substitution = "WAS_REPLACED";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}