use strict;
my $str = 'Lorem ipsum dolor sit amet, REPLACE_ME consectetur adipiscing elit.';
my $regex = qr/(REPLACE_ME)/imp;
my $subst = 'WAS_REPLACED';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";