using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(REPLACE_ME)";
string substitution = @"WAS_REPLACED";
string input = @"Lorem ipsum dolor sit amet, REPLACE_ME consectetur adipiscing elit.";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}