#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)(REPLACE_ME)"
Local $sString = "Lorem ipsum dolor sit amet, REPLACE_ME consectetur adipiscing elit."
Local $sSubst = "WAS_REPLACED"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)