package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(REPLACE_ME)`)
var str = `Lorem ipsum dolor sit amet, REPLACE_ME consectetur adipiscing elit.`
var substitution = "WAS_REPLACED"
fmt.Println(re.ReplaceAllString(str, substitution))
}