$re = '/(REPLACE_ME)/im';
$str = 'Lorem ipsum dolor sit amet, REPLACE_ME consectetur adipiscing elit.';
$subst = "WAS_REPLACED";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;