import Foundation
let pattern = #"(REPLACE_ME)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"Lorem ipsum dolor sit amet, REPLACE_ME consectetur adipiscing elit."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"WAS_REPLACED"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)