#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^\t\t\t\tcompile: function\s*\([^)]+\)\s*\{\s*return\s+function\s*\(\s*([^)]+)\s*\)\s*\{\s*([^}]+?)\s*};\s+}"
Local $sString = " compile: function(element, attrs, childTranscludeFn) {" & @CRLF & _
" return function ( scope, element, attrs, checkboxCtrl ) {" & @CRLF & _
" checkboxCtrl.init(scope.$parent.element);" & @CRLF & _
" };" & @CRLF & _
" }"
Local $sSubst = "\t\t\t\tlink: function($1) {\n\t\t\t\t\t$2\n\t\t\t\t}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)