re = /^\t\t\t\tcompile: function\s*\([^)]+\)\s*\{\s*return\s+function\s*\(\s*([^)]+)\s*\)\s*\{\s*([^}]+?)\s*};\s+}/
str = ' compile: function(element, attrs, childTranscludeFn) {
return function ( scope, element, attrs, checkboxCtrl ) {
checkboxCtrl.init(scope.$parent.element);
};
}'
subst = '\\t\\t\\t\\tlink: function($1) {\\n\\t\\t\\t\\t\\t$2\\n\\t\\t\\t\\t}'
result = str.sub(re, subst)
# Print the result of the substitution
puts result