import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\t\\t\\t\\tcompile: function\\s*\\([^)]+\\)\\s*\\{\\s*return\\s+function\\s*\\(\\s*([^)]+)\\s*\\)\\s*\\{\\s*([^\\}]+?)\\s*\\};\\s+\\}";
final String string = " compile: function(element, attrs, childTranscludeFn) {\n"
+ " return function ( scope, element, attrs, checkboxCtrl ) {\n"
+ " checkboxCtrl.init(scope.$parent.element);\n"
+ " };\n"
+ " }";
final String subst = "\\t\\t\\t\\tlink: function($1) {\\n\\t\\t\\t\\t\\t$2\\n\\t\\t\\t\\t}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}