// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\t\t\t\tcompile: function\s*\([^)]+\)\s*\{\s*return\s+function\s*\(\s*([^)]+)\s*\)\s*\{\s*([^}]+?)\s*};\s+}").unwrap();
let string = " compile: function(element, attrs, childTranscludeFn) {
return function ( scope, element, attrs, checkboxCtrl ) {
checkboxCtrl.init(scope.$parent.element);
};
}";
let substitution = "\\t\\t\\t\\tlink: function($1) {\\n\\t\\t\\t\\t\\t$2\\n\\t\\t\\t\\t}";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}