import Foundation
let pattern = #"^\t\t\t\tcompile: function\s*\([^)]+\)\s*\{\s*return\s+function\s*\(\s*([^)]+)\s*\)\s*\{\s*([^}]+?)\s*};\s+}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
compile: function(element, attrs, childTranscludeFn) {
return function ( scope, element, attrs, checkboxCtrl ) {
checkboxCtrl.init(scope.$parent.element);
};
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\t\t\t\tlink: function($1) {\n\t\t\t\t\t$2\n\t\t\t\t}"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}