$re = '/^\t\t\t\tcompile: function\s*\([^)]+\)\s*\{\s*return\s+function\s*\(\s*([^)]+)\s*\)\s*\{\s*([^}]+?)\s*};\s+}/';
$str = ' compile: function(element, attrs, childTranscludeFn) {
return function ( scope, element, attrs, checkboxCtrl ) {
checkboxCtrl.init(scope.$parent.element);
};
}';
$subst = "\t\t\t\tlink: function($1) {\n\t\t\t\t\t$2\n\t\t\t\t}";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;