const regex = /^\t\t\t\tcompile: function\s*\([^)]+\)\s*\{\s*return\s+function\s*\(\s*([^)]+)\s*\)\s*\{\s*([^}]+?)\s*};\s+}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\t\\t\\t\\tcompile: function\\s*\\([^)]+\\)\\s*\\{\\s*return\\s+function\\s*\\(\\s*([^)]+)\\s*\\)\\s*\\{\\s*([^}]+?)\\s*};\\s+}', '')
const str = ` compile: function(element, attrs, childTranscludeFn) {
return function ( scope, element, attrs, checkboxCtrl ) {
checkboxCtrl.init(scope.\$parent.element);
};
}`;
const subst = `\t\t\t\tlink: function($1) {\n\t\t\t\t\t$2\n\t\t\t\t}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);