use strict;
my $str = ' compile: function(element, attrs, childTranscludeFn) {
return function ( scope, element, attrs, checkboxCtrl ) {
checkboxCtrl.init(scope.$parent.element);
};
}';
my $regex = qr/^\t\t\t\tcompile: function\s*\([^)]+\)\s*\{\s*return\s+function\s*\(\s*([^)]+)\s*\)\s*\{\s*([^}]+?)\s*};\s+}/p;
my $subst = '\\t\\t\\t\\tlink: function($1) {\\n\\t\\t\\t\\t\\t$2\\n\\t\\t\\t\\t}';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";