# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^\s\w",](?:br\W*\s*)+)"$//g;t' <<< "\"hey, here i am<br /> test<br /><br />
\""