const regex = /([^\s\w",](?:br\W*\s*)+)"$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\s\\w",](?:br\\W*\\s*)+)"$', 'g')
const str = `"hey, here i am<br /> test<br /><br />
"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);