import Foundation
let pattern = #"([^\s\w",](?:br\W*\s*)+)"$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"hey, here i am<br /> test<br /><br />
"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)