using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\s\w"",](?:br\W*\s*)+)""$";
string substitution = @"";
string input = @"""hey, here i am<br /> test<br /><br />
""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}