$re = '/([^\s\w",](?:br\W*\s*)+)"$/';
$str = '"hey, here i am<br /> test<br /><br />
"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;