re = /([^\s\w",](?:br\W*\s*)+)"$/
str = '"hey, here i am<br /> test<br /><br />
"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result