use strict;
my $str = '"hey, here i am<br /> test<br /><br />
"';
my $regex = qr/([^\s\w",](?:br\W*\s*)+)"$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";