# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<toto>dogs) are the best (friends) of (humans), don't listen to what (cats) say\./$3 are the best slaves of $4, don't listen to what ${toto} say/gm;t' <<< "dogs are the best friends of humans, don't listen to what cats say.
"