const regex = new RegExp('(?<toto>dogs) are the best (friends) of (humans), don\\'t listen to what (cats) say\\.', 'gm')
const str = `dogs are the best friends of humans, don't listen to what cats say.
`;
const subst = `$3 are the best slaves of $4, don't listen to what ${toto} say`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);