import Foundation
let pattern = #"(?<toto>dogs) are the best (friends) of (humans), don't listen to what (cats) say\."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
dogs are the best friends of humans, don't listen to what cats say.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3 are the best slaves of $4, don't listen to what ${toto} say"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)