#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<toto>dogs) are the best (friends) of (humans), don't listen to what (cats) say\."
Local $sString = "dogs are the best friends of humans, don't listen to what cats say." & @CRLF & _
""
Local $sSubst = "$3 are the best slaves of $4, don't listen to what ${toto} say"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)