import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<toto>dogs) are the best (friends) of (humans), don't listen to what (cats) say\\.";
final String string = "dogs are the best friends of humans, don't listen to what cats say.\n";
final String subst = "$3 are the best slaves of $4, don't listen to what ${toto} say";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}