using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<toto>dogs) are the best (friends) of (humans), don't listen to what (cats) say\.";
string substitution = @"$3 are the best slaves of $4, don't listen to what ${toto} say";
string input = @"dogs are the best friends of humans, don't listen to what cats say.
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}