$re = '/(?<toto>dogs) are the best (friends) of (humans), don\'t listen to what (cats) say\./m';
$str = 'dogs are the best friends of humans, don\'t listen to what cats say.
';
$subst = "$3 are the best slaves of $4, don't listen to what ${toto} say";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;