# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a[^>]*herf=''[^>]*>(.*?)<\\/a>/$1/g;t' <<< "this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a> this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a> this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a>"