import Foundation
let pattern = #"<a[^>]*herf=''[^>]*>(.*?)<\/a>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a> this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a> this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)