use strict;
my $str = 'this is a bet and he is <a herf=\'\'>Mansoon</a> and he please search on <a href=\'http://www.google.com\'>Google</a> and say he <a herf=\'\'>Yammy</a> this is a bet and he is <a herf=\'\'>Mansoon</a> and he please search on <a href=\'http://www.google.com\'>Google</a> and say he <a herf=\'\'>Yammy</a> this is a bet and he is <a herf=\'\'>Mansoon</a> and he please search on <a href=\'http://www.google.com\'>Google</a> and say he <a herf=\'\'>Yammy</a>';
my $regex = qr/<a[^>]*herf=''[^>]*>(.*?)<\/a>/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";