import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a[^>]*herf=''[^>]*>(.*?)<\\/a>";
final String string = "this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a> this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a> this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a>";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}